Introduzione

Questo è un articolo dettagliato. Per una guida veloce leggere il seguente articolo: come cambiare versione di PHP.

Ubuntu 16.04 di default utilizza PHP 7.0. Installiamo anche PHP 5.6.

Con PHP 7.0 potreste avere problemi di compatibilità con qualche applicazione meno recente.

Consiglio di non rimuovere PHP 7.0 perché potreste avere problemi con altre applicazioni, come per esempio il pacchetto ufficiale di phpmyadmin su Ubuntu richiede PHP 7.0.

Per installare e utilizzare entrambe le versioni di PHP per poi cambiarle all'occorrenza procedere in questo modo:
Aprire un terminale e dare questi comandi:

sudo add-apt-repository ppa:ondrej/php

sudo apt-get update

sudo apt-get install php7.0 php5.6 php5.6-mysql php-gettext php5.6-mbstring php-mbstring php7.0-mbstring php-xdebug libapache2-mod-php5.6 libapache2-mod-php7.0

Installazione terminata.

Cambiamo versione di PHP.

Da PHP 7.0 a PHP 5.6:

Apache:

sudo a2dismod php7.0 ; sudo a2enmod php5.6 ; sudo service apache2 restart

CLI:

sudo update-alternatives --set php /usr/bin/php5.6

Da PHP 5.6 a PHP 7.0:

Apache:

sudo a2dismod php5.6 ; sudo a2enmod php7.0 ; sudo service apache2 restart

CLI:

update-alternatives --set php /usr/bin/php7.0